
Exercise
A. 1. Light pen; 2. Touch screen; 3. Printer; 4. Plotter
B. 1. The CPU is the brain of a computer system. 
 2. Memory chips are one of the important components of computer 

hardware. 
 3. A joystick is an input device. 
 4. A barcode reader is a device used to read barcodes. 
 5. computer is an electronic device. 
C. 1. motherboard; 2. soundcard; 3. SMPS; 4. hard disk; 5. BIOS
D. 1. T; 2. T; 3. T; 4. T; 5. F
E. 1. A motherboard is the main board that holds many of the crucial 

components of a computer system. It allows all the parts to receive 
power and communicate with one another.

 2. Input devices : mouse, keyboard
  Output devices: printer, monitor
 3. Printer
  Printer is the most important output device, which is used to print output 

on paper.
  There are two types of printers : Impact printer and Non-Impact printer.
  1. Impact Printer
  Impact printer prints the characters by striking against the ribbon on to 

the paper. These are used for bulk printing due to their low costs and 
their compatibility to print any language characters but are too noisy and 
slow.  

  2. Non-impact Printer
  Non-impact printer does not strike the print head against the ink ribbon 

and hence generates less noise. These printers are faster than the impact 
printers.

 4.

 5. A light pen is also an input device. It is shaped like a pen. A light pen is 
connected to the VDU. It allows the user to draw or point to objects on 
the computer screen or the monitor.

INFORMATION TECHNOLOGY-1Information Technology-5

The Versatile Computer1

Hardware
1. All the physical parts of a 

Computer are called hardware.

2. We can see the hardware.
3. We can touch these.
4. Examples: mouse, keyboard 

monitor etc.

Software
1. These are not physical, but a 

set of programs.
2. We can’t see the software.
3. We can not touch these.
4. Examples: Windows Operating 

system, MS word etc.
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F. 1.  MICROPHONE; 2. BARCODE READER; 3. PLOTTER; 4. MOTHERBOARD
Fun to Do
Do yourself.

Computer Software2
Exercise

A. 1. System software; 2. Windows; 3. Symbian; 4. Utillity sofware; 
 5. Spreadsheet software
B. 1. Operating system; 2. Utility software; 3. tool; 4. Disk cleaner; 5. drivers
C. 1. MS-DOS     a. Macintosh
 2. UNIX     b. Microsoft
 3. LINUX     c. First operating system for PC
 4. Mac OS     d. Oracle, Sun Microsystems
 5. Windows    e. Android
D. 1. System software is a collection of programs that manages the resources 

and operations of a computer system. It performs tasks such as 
processing of data and information, controls hardware components and 
allows users to use application software.

 2. Application software is a set of programs that runs on system software 
and allow users to perform specific tasks. They can process text, 
numbers, graphics or a combination of these. Application software are 
also known as Apps.

 3. LINUX is a popular variant of the UNIX operating system. It can be used as 
a server OS or a desktop OS, in other devices.

 4. It allows users to create image, audio, video, etc.
 5. An Operating system is a collection of computer programs that manages 

CPU operations, input/output activities, storage resources, support 
services, controls various devices.

 6. Windows is an operating system developed by Microsoft for personal 
computers. It is the mostly used OS in personal computers.

E. 1. Batch Processing
 It is an efficient way of 

processing high volume of 
data.

 It requires seperate programs 
for input.

 It is used in payroll system.
 Examples: Billing system

Real time operating system
 It involves a continual input, 

process and output of data.
 It requires continual input.
 Real time operating system 

are used in customer service 
centre.

 Examples: ATM
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 2. Operating system : An operating system is a collection of computer 
programs that manages CPU operations, input/output activities, storage 
resources, support services and controls various devices.

  Device Drivers : All hardware need software called drivers to 
communicate with other software. For example, a printer needs a print 
driver to understand the commands given by another application.

 3. UNIX : UNIX is used in server products like Oracle, Sun Microsystems, 
Silicon Graphics, IBM, HP, Digital and other companies.

  LINUX : LINUX is a popular variant of the UNIX operating system. It can be 
used as a server OS or a desktop OS, in other devices.

 4. Windows : Windows is an operating system developed by Microsoft for 
personal computers. It is the most used OS in personal computers.

  Z/OS : Z/OS is an operating system development by IBM for mainframe 
computers. Operating systems, like Symbian, are found on small devices 
such as cell phones and PDAs.

 5. Word Processing Software : It allows users to create, edit a document. 
Example : MS Word, WordPad, etc.

  Spreadsheet Software : It allows users to create documents and perform 
calculations. Example : Excel, Lotus 1-2-3, etc.

F. 1. Software is a program that enables a computer to perform a specific task 
such as input, processing or output.

 2. System software, programming software and application software.
 3. System software : System software is a collection of programs that 

manages the resources and operations of a computer system. It 
performs tasks such as processing of data and information, controls 
hardware components and allows users to use application software.

  Application software : Application software are the set of programs that 
are run on system software and allow users to perform specific files. They 
can process text, numbers, graphics or a combination of these. 
Application software are also known as Apps.

 4. Operating system, system utilities program, device drivers, translator.
 5. (i) It helps to schedule the CPU processing for different applications.
  (ii) It helps to run application software such as Paint, MS PowerPoint, etc.
  (iii) It manages input and output.
 6. Word processing software, spreadsheet software, database software, 

multimedia software.
Fun To Do
Do yourself
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Exercise

A. 1. Operating system; 2. simple opaque rectangles or squares; 3. Mail 

app; 4. Metro-style apps

B. 1.  live tile; 2. real time; 3. metro-style apps; 4. Mail app; 5. flyout

C. 1.  T; 2. T; 3. F; 4. F; 5. T

D. 1. Windows 8 is an operating system that controls all the operations of a 

computer. It is the second most recent version of Microsoft Windows. It 

is one of the most popularly used operating system. It is produced to use 

on personal computers including home and business desktops, laptops, 

netbooks, tablets, and media centre PC’s. It provides a Graphical User 

Interface.

 2. Live tiles on the Windows 8 are simple opaque rectangles or squares, and 

they’re arranged automatically on the Start screen in a grid-like pattern.

 3. The Mail app let us create tiles for individual e-mail folders.

 4. Once you've matched this app with one or more accounts, it will begin 

dynamically displaying upcoming appointments on its tile. Oftentimes, 

that information is all you need to know, eliminating the need to actually 

launch the app and view the appointment manually.

 5. Deep linking is the use of hyperlink that links to a specific, generally 

searchable or indexed, piece of web content on a website.

E. 1. Windows 8 is an operating system that controls all the operations of a 

computer.

 2. Simply right click or tap and hold the tile that we want to resize, go to 

Resize option and choose the size that we want.

 3. To disable live updating for a single tile, select it (right click, or tap and 

drag down slightly) and then choose Turn live tile off from the app bar 

that appears.

 4. The Mail tile works similarly, though it you will cycle through up to five of 

your most recent e-mails and provide a badge, in the lower right corner, 

that displays the number of unread e-mails.

 5. Deep linking is the use of a hyperlink that links to a specific, generally 

searchable or indexed, piece of web content on a website.

  It provides a way for us to add a new tile for the app, from within the app 

itself, which causes the app to open with a specific experience displayed.

More About Windows 83
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 6. Tiles are designed specifically to display real time information 

dynamically, even when the underlying app isn’t running. The tile can use 

various kinds of text in different layouts, images, e-mails, perhaps or 

similar.
Fun To Do
Do yourself

More on MS PowerPoint 20104
Exercise

A. 1. Tables; 2. Sound; 3. Tables; 4. animation; 5. Autoshapes; 6. transition; 
7. Animation; 8. clicking, dragging

B. 1. T; 2. T; 3. T; 4. F; 5. T; 6. T; 7. F
C.  Column A     Column B
 1. Tables     a.  Clip organizer, CD, Recording
 2. Photo album    b.  Special effect to determine appearance 

of slides
 3. Inserting sound   c.  Organizing information systematically
 4. Transition    d.  Emphasizes on important information
 5. Animation    e.  help to draw geometrical figures
 6. Autoshapes    f. Easy way to create a slide show
D. 1. Step 1. Click on the Insert tab.
  Step 2. Choose the Photo Album option from the ‘Images’ group. Select 

New Photo Album from the displayed option. A ‘Photo Album’ 
window opens. Select Insert Picture from the ‘File/Disk.

  Step 3. The ‘Insert New Pictures’ window opens from where we can 
select pictures. The window also gives options to search for 
photos from different places like Documents, Desktop and 
Network Places. Once we have selected the photo, we click on 
Insert. After selecting the pictures, click on Insert button.

  Step 4. The photos will be displayed in the preview box of ‘Photo 
Album’ window. The list of photos will be shown in ‘Picture’ in 
‘Album’ box.

  Step 5. There is an option available on the Photo album window to 
insert text. On clicking on the New Text box, a text box gets 
added to the list of photos.

  Step 6. Click on Create to add the photos and the text box in the 
presentation.

 2. The various steps to apply a built-in animation effect are listed below :
  Step 1 :  Select the slide that has to be animated.
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  Step 2 :  In the Transitions tab, select an animation (slide transition) 
effect from the Transition To This Slide group.

 3. Adding movement to graphics creates a dynamic and visual guide to the 
information being delivered.

  Animated presentations with motion effects can help us pace the 
delivery of information and enhance visual interest.

 4. Step 1. Select the text of object that has to be animated.
  Step 2. Click on Add Animation in ‘Advanced Animation’ group of 

‘Animations’ tab.
  Step 3. Click on the desired animation effect from the various groups.
 5. Step 1. Click on the Insert tab and choose Audio from ‘Media’. A drop-

down box appears. Select Audio from ‘File’ from the options 
available.

  Step 2. In the dialog box that opens, select the file and click on OK.
 6. AutoShapes are drawing features that help us to draw different 

geometrical figures such as rectangle, triangle and ellipse. These shapes 
can be resized, rotated, flipped and coloured.

  Follow the given steps to insert shapes in a slide :
  Step 1 :  Click on the Insert tab.
  Step 2 :  Choose the Shapes option from the Images group.
  Step 3 :  Choose a shape from the options available, and move the mouse 

to the slide.
  Step 4 :  Click the mouse to place the shape.
Fun To Do
Do yourself

More on MS Excel 20105
Exercise

A. 1. undo; 2. Ctrl+A; 3. Paste; 4. Auto Format; 5. F2
B. 1. border button; 2. reverse the last action;  3. border; 4. tables
C. 1. T; 2. F; 3. T; 4. T; 5. T
D. 1. Workbook; 2. Cell; 3. An active cell; 4. Editing; 5. Redo

E. 1.      a. Merge and Centre

 2.     b. Fill Color

 3.     c. Cut

 4.     d. Border

 5.      e. Auto Format
F. 1. Follow the steps given below to cut the data from a cell or a range of cells :
  Step 1. Select the cell or the range of the cells to be cut.
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  Step 2. Click on the Home tab.
  Step 3. In the Clipboard group, click on the Cut command.
  Follow the steps given below to copy the data in a cell or a range of cells :
  Step 1. Select the cell or the range of cells to be copied.
  Step 2. Click on the Home tab.
  Step 3. In the Clipboard group, click on the Copy command.
  Follow the steps given below to paste the data in a cell or a range of cells :
  Step 1. Select the cell or the range of cells where you want to paste the 

cut or copied data.
  Step 2. Click on the Home tab.
  Step 3. In the Clipboard group, click on the Paste command.
 2. The Undo feature allows you to cancel the last steps you performed in the 

Worksheet.
  The opposite of Undo is Redo. To redo the last action, click on the Redo 

command on the Quick Access Toolbar.
 3. Formatting implies changing the appearance of text. For example, 

changing  the font, font size and colour.
  (i)  Step 1. Select the cell or the range of cells where you want to change 

the font and its size.
   Step 2. Click on the Home tab.
   Step 3. In the Font group, click on Font. A drop down list of fonts 

appears. Select a font from the list displayed.
   Step 4. Click on the Font size arrow in the Font group. A drop down 

list of font sizes appears. Select the font size from the list displayed.
  (ii)  Step 1. Select the cell or the range of cells where you wish to change 

the style.
   Step 2. Click on the Bold, Italic or Underline option in the Font group 

on the Home tab.
  (iii)  Step 1. Select the cell.
   Step 2. Click on the Home tab.
   Step 3. In the Cells group, click on the Delete arrow and then select 

Delete Cells.
   The Delete dialog box appears showing four options.
   Step 4. Click on Delete Sheet Rows.
   Step 5. Click on OK to delete rows.
 4. Step 1. Select the first cell in the required range of cells.
  Step 2. Press Ctrl key on the keyboard and click on the other cells that are 

to be selected.
 5. If the value that we enter in one or two adjacent cells match an existing 

entry or follow a pattern, excel will automatically enter the remaining 
characters of the series for us.

Fun To Do
Do yourself
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Internet6
Exercise

A. 1.  Tim Berners-Lee; 2. All are correct; 3. ISP; 4. Web browser; 5. Modem;  
 6. All are correct; 7. URL; 8. Compose mail
B. 1. Mozilla Firefox, Opera
 2. Airtel, Reliance
 3. Yahoo.com, Gmail.com
 4. Google.com, Altavista.com
C. 1. Net; 2. web browser; 3. home page; 4. Electronic Mail; 5. Inbox; 6. Create; 7. 

Tim berners- Lee
D. 1. T; 2. F; 3. T; 4. F; 5. T
E. 1. Internet Service Provider
 2. Modulator Demodulator
 3. Mahanagar Telephone
 4.  Advance Research Projects Agency Network
F. 1. Inbox; 2. Compose mail; 3. Forward; 4. Sent mail; 5. Reply
G. 1. It accepts and sends messages through telephone wire.
 2. An act of browsing the internet by going from one webpage to another.
 3. It contains a lot of information in the form of pages.
 4. It is a program that is used to surf the net.
H. 1. Internet is the largest network of computers. Internet is commonly called 

as the Net or Cyberspace.
 2. It is called as an Electronic Mail. It is the most commonly used feature of 

any website for sending and receiving messages.
 3. (i) Internet is used for sending and receiving messages, through E-mail.
  (ii) Search engines on the net, helps you in searching information on any 

topic.
  (iii) We can play online games, participate in quizzes, crosswords.
 4. Step 1. Open the site for example www.gmail.com.
  Step 2. Click on Create an Account.
  Step 3. Fill in the form.
 5. a. WWW is a part of Internet, which is the largest collection of special 

sites related to various fields.
  b. A website contains a lot of information in the form of pages about an 

organisation, or an individual.
  c. Each website is alloted a unique identification name called Uniform 

Resource Locator (URL).
  d. A web page contains information in the form of text, picture, video, 

audio and animation.
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  e. It contains the address or URL of the website which you want to visit.
 6. A Search engine is a software program which helps in finding websites, 

web pages, and Internet files. Search engines are particularly helpful in 
locating web pages on certain topics or in locating specific pages for 
which you do not know the exact URL. Some search engines look through 
web pages for all types of information. Others can restrict their searches 
to a specific type of information, such as images, videos, audios, news, 
maps, people or businesses, and blogs.

Fun To Do
Do yourself

Computer Malware7
Exercise

A. 1.  Worm; 2. Trojan Horse; 3. Antivirus; 4. E-mail 
B. 1. Antivirus; 2. Computer virus; 3. Virus; 4. e-mail; 5. e-mail
C. 1. T; 2. T; 3. T; 4. T; 5. T
D. 1. A Computer Virus is a software program that spreads from one computer 

to another computer without the permission or knowledge of the user 
and interferes with computer operations.

 2. A computer can get injected by a computer virus as in following ways : 
   The computer runs slower than usual.
   The computer stops responding or it locks up frequently.
   The computer crashes, and gets restarted after every few minutes.
   Applications on the computer do not work properly.
   Disks or disk drives are inaccessible.
   Unusual error messages are displayed again and again.
   Distorted menus and dialog boxes are displayed.
   There is double extension on an attachment that you recently 

opened, such as jpg, vbs, gif or exe execution.
   Antivirus programs get disabled for no reason.
 3. Antivirus software is used to prevent, detect and remove malware and 

other computer viruses. You should install an antivirus program to 
safeguard your computer from virus attacks and update it regularly. An 
antivirus program protects a computer against the viruses by identifying 
and removing any computer viruses found in memory, on storage media 
or on incoming files. 

 4. Malware (a portmanteau for malicious software) is any software 
intentionally designed to cause damage to a computer server or 
computer network. The code is described as computer viruses, worms, 
trojan horses, ransomware, spyware, adware, and scareware, among 
other terms.
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 5. a. A Computer Virus is a software program that spreads from one 
computer to another computer without the permission or 
knowledge of the user and interferes with computer operations.

  b. It is a quite harmless virus that simply replicates itself. But in the long 
run, it takes overall resources of the system and the PC becomes 
useless. Worms have the capacity to travel from system to system 
very easily.

  c. This virus comes as a friendly program (as a game, etc.). But it is very 
dangerous as it destroys all data. Trojan horses do not replicate 
themselves but they can be very destructive. 

 6.  Some symptoms of a computer virus in a computer system are given 
below : 

   The computer runs slower than usual.
   The computer stops responding or it locks up frequently.
   The computer crashes, and gets restarted after every few minutes.
   Applications on the computer do not work properly.
   Disks or disk drives are inaccessible.
   Unusual error messages are displayed again and again.
   Distorted menus and dialog boxes are displayed.
   There is double extension on an attachment that you recently 

opened, such as jpg, vbs, gif or exe execution.
   Antivirus programs get disabled for no reason.
Fun to Do
Do yourself.
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