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Computer System1
Exercise

A.  Tick (3) the correct option :
Ans. 1.  c.   2.  c.   3.  c.   4.  b.  
B.  Fill in the blanks :
Ans. 1.  A mouse is also called a pointing device.
 2.  It captures pictures and text from papers and makes their digital copy.
 3.  QR code is the short form for Quick Responce code.
 4.  A digital camera is used to capture images or videos and store them in 

a digital format.
C.  State ‘True’ or ‘False’ :
Ans. 1.  True 2.  False 3.  True 4.  True
D.  Answer the following questions.
Ans. 1.  A computer is an electronic device that stores, recovers, processes and 

does programming of data and instructions. It consists of hardware and 
software. It exists in different sizes and configurations. A computer 
normally :

   Inputs the data from the mouse and the keyboard.
   Processes the data from the CPU and the memory.
   Outputs the result on the monitor screen.
   Saves the data on storage devices such as the hard disk.
 2.  Devices through which data and instructions are entered into a 

computer are called input devices. An input device converts these 
instructions and data into electrical signals that are recognized by the 
computer.

 3.  Graphic tablet is an input device used to create drawings. 
 4.  A QR code is a two-dimensional code that consists of an array of black 

and white squares. QR code is a short form for Quick Response code. 
You must have noticed QR codes on business cards, billboards, 
products and so on.

 5.  A touchscreen is a touch-sensitive computer display screen that can 
also act as an input device. It can identify the presence and position of a 
touch within the display region.

  Touchscreens are easy to use and are often found in public places such 
as ATMs, ticket collection terminals, theatres and airports. It is used 
extensively in design of appliances such as mobile phones.

Lab Activity
Ans. Do it yourself.
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Computer Memory2
Exercise

A.  Tick (3) the correct option : 
Ans. 1.  a.    2.  c.   3.  d.    4.  c.  
B.  Fill in the blanks :
Ans. 1.  ROM is non-valatile memory as it retains the contents even when the 

power is switched off.
 2.  DOS is an example of operating system.
 3.  Application software is a set of programs necessary to carry out the 

operations for a specified application.
 4.  A hard disk consists of a spindle that holds one or more disks called 

platters.
C.  State ‘True’ or ‘False’ :
Ans. 1.  True 2.  True 3.  False 4.  True 5.  False
D.  Answer the following questions :
Ans. 1.  Compile : It is a language translator that translates the high-level 

language program into machine language (computer language). It 
converts the entire program in one go and reports all the errors of the 
program along with their line numbers at the end. For example, C 
language has a compiler.

 2.  Application software is a set of programs necessary to carry out 
operations for a specified application. These are the programs written 
by programmers to enable computers to perform a specific task. 

 3.  RAM–It stands for Random Access Memory.
  i.  The CPU (Central Processing Unit) uses this memory while 

processing information.
  ii.  This is also called read/write memory.
  iii.  This memory is temporary in nature.
  ROM–ROM is the computer memory on which data has been pre-

recorded. Once data has been written onto a ROM chip, it cannot be 
erased and can only be read. ROM is a non-volatile memory as it retains 
the contents even when the power is switched off.

 4.  Primary Memory–It is the main part of a computer and determines the 
size and number of programs (software) that can be stored in a 
computer as well as the amount of data that can be processed.

  Secondary Memory–Secondary memory differs from the primary 
memory by the fact that the CPU cannot use this memory directly while 
processing the information.

 5.  Utilities are those application programs that assist a computer by 
performing housekeeping functions like backing up disk or 
scanning/cleaning viruses or arranging information etc. They ensure 
the smooth functioning of a computer.

  Some important utilities are text editor, used for creating and editing 
text files, backup utilities that facilitates the backing-up of disks, 
compression utility that facilitates compression of files, disk 
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defragmentation utility that attempts to minimise the fragmentation on 
your disk, and antivirus software that ensures a virus-free environment.

Lab Activity
Ans. Do it yourself.

Programming Languages3
Exercise

A. Tick (3) the correct option :
Ans. 1. c.  2.    a  3.    b
B. Fill in the blanks :
Ans. 1. Basically, computers perform operations on objects.
 2. Most programming languages describe computation in an imperative 

style.
 3. Object-Oriented (OO) languages are the most common these days.
 4. BASIC combines both programming and computer control into a 

single interface.
 5. You will need to put CLS at the very top of your program to clear the 

screen before you print anything.
C. State 'True' or 'False':
Ans. 1. True  2.  False 3.  True 4.  True 
 5.   False  6.  False 7.  False
D. Define the following :
Ans. 1. Programming language : A programming language is a language 

which is used to express a set of instructions in such a manner that the 
computer can understand and follow its instructions.

 2. Procedural languages : Procedural languages are the type of 
computer programming languages that specify a series of well-
structured steps and procedures with in their programming context to 
compose a program.

 3. Stack Languages : Stack-based language is are one-in which a stack, 
implicitly accessed by most operations, is a fundamental part of the 
programming model.

 4. QuickBASIC–It is the origin of all modern BASICS. A few people 
have spurred a cult for the language, as many games and tutorials based 
on QuickBASIC are available on the Internet.

 5.  DarkBASIC–A significant commercial variant of BASIC, which 
utilizes the DirectX library and is great for writing games quickly.

 6. QBASIC Editor–If you've used your computer to do school work or 
write a report, you'll notice that most of the ending keys 
(<Backspace>, <Delete>, <Insert>...) work just the way they always 
do. In case you haven't used these keys before, here's a list :

   <Backspace>  Removes the character to the left of the cursor
   <Delete>  Removes the character at the cursor
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   <Left Arrow>  Moves the cursor left
   <Right Arrow>  Moves the cursor right
   <Up Arrow>  Moves the cursor up
   <Down Arrow>  Moves the cursor down
   <Home>   Moves the cursor to the start of a line
   <End>  Moves the cursor to the end of a line
E. Answer the following questions :
Ans. 1. A computer language is a language which is used to express a set of 

instructions in such a manner that the computer can understand and 
follow these instructions.

 2. Object-oriented (OO) languages are the languages in which objects 
bundled together values and commands in a single entity programs, 
and collections of interacting objects.

 3. OO language can be seen as an attempt to solve the problems that was 
experienced with procedural language, where changing values could 
introduce subtle bugs that were difficult to track down. In practice, it is 
possible to program in an 'OO style' with many procedural languages. 
This can be done simply by following careful convections or it can 
involve exploiting other language features to enforce encapsulation. In 
C, for example structs can be used with function pointers to create ad-
hoc object.

  The general idea is that each object manages its own values using the 
code in its methods, to change the values in a separate object the 
method is that object should be called.

  The idea that each object is uniquely responsible for managing its own 
values is called encapsulation.

 4. Functional languages are considered more declarative than, OO or 
procedural ones, and lazy evaluation also helps. The idea can be taken 
further by automating the process of searching for a solution to 
relationships defined by the programmer. In other words, a program 
consists of a list of desired relationships; executing the program is 
equivalent to finding a solution that satisfies all the relationships.

  There are various ways in which this can be implemented, depth or 
breadth first search, or by enumerating all possibilities. Some 
languages allow the programmer to improve efficiency and/or control 
memory use by, for example, indicating where backtracking is not 
needed.

 5. FORTRAN  Scheme   CLOS
  LISP   CSP   Oberon
  APL   dBASE II
  BASIC  Ada
 6. Types of BASIC can be divided into several groups, on the basis of 

their usage and ability such as:
  Their platform (Windows, Linux, etc.)
  Their application/purpose (games, GUI applications, etc.)
  Their ability to be compiled or interpreted
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 7. QBASIC, a shareware is a limited version of the commercial software 
QuickBASIC. While QBASIC is shareware, QuickBASIC is 
commercial software. 

 8. To get started with QBASIC, follow these steps :
  Step 1. Start Command Prompt : On Windows desktop, click on Start 

button then type CMD in Search file and Programs input box. 
CMD will be on the top of the menu.

  Step 2. Click on CMD, Command Prompt will be appearing. Write 
QBASIC and Press Enter key, if you get a blue screen with 
something about a 'Survival Guide', you made it! Now 
QBASIC Window is visible to you. If instead you got 
something about a 'Bad command or file name', you need to 
get QBASIC installed on your machine.

   Go ahead and press the <Esc> key to 'clear this dialog box' 
when it asks you to.

Lab Activity
 Do it yourself.

More About Windows 84
Exercise

A. Tick (3) the correct option :

Ans. 1. b.  2.   a.  3.  c.

B. Fill in the blanks :

Ans. 1. Press the Window + C key to open charms menu to the right of the screen.

 2. To navigate through the Start screen, either click on and drag the scroll 
bar at the bottom of the screen.

 3. The Lock screen is also called the Welcome screen.

C. State 'True' or 'False' :

Ans. 1. False  2. True  3. False

D. Answer the following questions :

Ans. 1. The functions of the Windows Start button have been replaced with a 
new Start screen-colored tiles that are shortcuts to programs and live 
widgets that report data from those programs. For example, on the 
Weather app, you can see the current temperature and forecast. On the 
Mail app, you can see how many unread e-mail messages you have and 
view reminders for upcoming events.

  The new Start screen gives you a larger desktop by expanding the 
borders left and right. 

 2. You can customize your Start screen by changing the name or 
appearance of a group of tiles, and then organize your Start screen by 
creating new groups for frequently used or similar apps.

 3. Customizing The Lock Screen
  The steps of customizing the Lock screen are :
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  Step 1:  Press the Windows (      ) + C key. The charms menu opens up 
to the right of the screen.

  Step 2:  Click on the Settings.
  Step 3: Click on the Change PC settings, and then click on Lock 

screen.
  Step 4:  You can change the desktop background picture by choosing 

one of the pictures available in your computer, or you can 
browse your computer for a picture.

  Step 5:  You can also view a Slide Show on the Lock screen. Move the 
slider to the ON position and then select a picture source.

  Step 6: In the Lock screen apps area, you can choose which app you want 
to run in the background to provide status and notifications.

 4. The Lock screen (also called the Welcome screen) covers the sign-in 
screen and displays the date and time, as well as notifications for email, 
calendar, and other apps. You can customize the lock screen by 
changing the picture and choosing which apps display notifications.

Lab Activity

 Do it yourself.

Exercise
A. Tick (3) the correct option :

Ans. 1. d.  2.    c.  3.    a.  4.    c.  5.    a.

B. Fill in the blanks :

Ans. 1. Sound card is used to record sounds in computer.

 2. Windows multimedia tool, Windows Sound Recorder is used for 
recording and playing the recorded sounds in computer.

 3. Media Player is a versatile windows multimedia application used to 
play sound as well as video CD's.

 d. Volume Control dialog box is used to adjust volume of the different 
sound devices.

C. State 'True' or 'False':

Ans. 1. True  2.  True 3.  False 4.  False 5.  True

D. Match the following :
Ans. 1.     b. Record
 2.     c. Play
 3.     e. Stop
 4.     a. Seek to start
 5.     d. Seek to end

E. Very short answer type questions :

Ans. 1. Digital camera   2. Macromedia Flash
 3. Multimedia Technology

Multimedia Applications in Windows5
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F. Short answer type questions :

Ans. 1. Multimedia is a combination of two words : Multi and Media. Multi 
means 'many' and Media means 'modes of communication'. So, 
multimedia is a computer technology which enables their machine to 
communicate in various modes like, text, graphics, sounds, movies and 
animations.

 2. A multimedia computer can play audio and video files on it. To do this, 
it needs some additional hardware. For playing audio and video files, 
apart from the CD-drive which is now an essential component of the 
computer, it needs a sound card, a graphics card and speakers.

 3. Multimedia has made the computer popular among all segments, from 
a child to an adult, because of its extensive applications like :

  Entertainment : Think of cartoon films or movies like, Stuart Little, 
Jurrasic Park, Spiderman, Godzila, etc. which are the examples of 
multimedia technology. The 3-D games you play on computer are also 
the examples of multimedia.

  Education : The various educational CD's available on different 
subjects have made the studies more interactive and interesting by 
adding animation and sound in them.

  Advertising : This technology is widely used nowadays to make TV 
ads in a more attractive manner.

  Business : It helps a businessman to take attractive presentations to 
display their product information to its customers in a more interactive 
manner.

 4. To record the sound :

  a. Connect a microphone to your computer.

  b. Click New option in the File menu.

  c. Click the Record button to start recording and speak in front of the 
microphone.

  d. To stop recording click Stop button.

  e. To save the recorded sound, click Save option in the File menu. 
Your sound file will be saved with extension .WAV.

 5. To start Media Player :

  Click Start ® Programs ® Accessories ® Entertainment ® Windows 
Media Player

 6. To run audio or video files stored in your computer :

  a. Choose Open option in the File menu of Windows Media Player. 
Open dialog box is displayed.

  b. Browse the audio/video file stored in the computer.

  c. Click on Open button to start the selected song or movie.

 7. Click Start ® Programs ® Accessories ® Entertainment ® Volume 
Control.

  Volume Control dialog box appears using which you can control the 
sounds of your computer multimedia applications like CD-player, 
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Cells

Column I Column 2

Row 1
Row 2

Row 3

DVD player, Sound Recorder, etc. Adjust the various tabs on the 
Volume Control dialog box to set the volume and balance for each 
device.

Lab Activity

Ans. Do it yourself.

More on MS Word 20106
Exercise

A. Tick (3) the correct option :

Ans. 1. b. 2.   d. 3.   b.
B. Fill in the blanks :
Ans. 1. To add a new line within a cell, press Enter key.
 2. Header is a text that is printed at the top of each page.
 3. You can merge and even split cells of a table.
 4. Table is made up of horizontal rows and vertical columns.
 5. The Insert table dialog box is accessed from the Table menu.
C. State 'True' or 'False':

Ans. 1. True  2.   True 3.   False 4.   True 5.   False
D. Define the following :
Ans. 1. Header–Header is a text that is printed at the top of each page.
 2. Footer–Footer is a text that is printed at the bottom of each page.
 3. Table–A table is made up of horizontal rows and vertical columns.
 4. Cell–The intersection of a row and a column is called a cell.
 5. Footnotes–Footnotes can be found at the end of the page.
 6. Messing calls–These cells are used to create one united merged cell.
E. Differentiate between the following :
Ans. 1. Header and Footer–Header is a text that is printed at the top of each 

page. They may be book's name or chapter's name etc. Where as footer 
is not at the top of the page, it is at the bottom of the page. They may be 
page no, or book no, etc.

 2. Footnote and Endnote–Footnotes and Endnotes can be found at the 
end of a page or the end of a document, respectively. These are 
generally used by authors when writing books. They can provide an 
author's comments on the main text, or give the meaning of or related 
details about the marked text.

 3. Table and Cell–A table is made up of horizontal rows and vertical 
columns. The intersection of a row and a column is called a cell. You 
can enter any type of information, in the form of text or graphics in a 
cell.
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 4. Merging and Splitting Cells–You can merge and even split cells of a 
table.

  To merge cells, follow these steps :
  Step 1. Select the cells which you want to merge.
  Step 2. Click on Merge Cells in the Merge group on the Table Tools 

Layout tab.
  It will merge all the selected cells.
  To split cells, the steps are as follows :
  Step 1. Click on the cell(s) which you want to split.
  Step 2. Click on Split Cells in the Merge group on the Table Tools 

Layout tab.
  The Split Cells dialog box appears.
  Step 3. Specify the number of columns and rows, and click on OK.
F.  Replace the incorrect word with correct word in the following 

sentences :
 1.  The text which is at the top of the page is called header.
 2.  Footnotes and endnotes can be found at the end of a page and at the 

end of a document respectively.
 3.  Footnotes are given at the end of the document.
 4.  To insert footnotes and endnotes first we click on Footnotes launcher 

footnotes group.
 5.  A table is made up of horizontal rows and vertical columns.
 6. Table button is limited to eight rows and ten columns.
 7. Using Quick Tables option, you can select a pre-designed table 

template and insert in your word document.  
G. Answer the following questions :
Ans. 1. Tables are used to place information into rows and columns. 

Alternatively, you can use tables as away to position images. Word 
tables are the perfect way to display complex usual information in a 
page.

 2. To insert header and footer in your document, follow these steps :
  Step 1. Click on the Insert tab.
  Step 2. In the Header & Footer group, click on the Header button. The 

Header gallery will open.
  Step 3. Click on the Blank header style or choose any other style 

according to your requirement. The Design tab will appear 
under Header & Footer Tools. This tab will come only when 
your cursor is in the header or footer area.

  Step 4. Type the header text in the header area.
  Step 5. Click on Go to Footer button in the Navigation group. The 

cursor appears in the footer area. Type the text in the footer 
area.

   OR
   Click on the Insert tab. In the Header & Footer group, click on 

Footer to display the Footer gallery. Click on the footer style 
you want. Type the text in the footer area.
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  Step 6. Click on Close Header and Footer button in the Close group of 
Design tab or press the Esc key.

 3. Inserting Footnotes and Endnotes :
  To insert footnotes and endnotes, follow these steps :
  Step 1.  Place the cursor where you want to insert a footnote or 

endnote.
  Step 2. Click on the References tab. In the Footnotes group, click on 

Insert Footnote or Insert Endnote button.
   This inserts the note reference mark immediately.
  Step 3. Type the required text for the footnote/ endnote.
  Step 4. Double click on the footnote/endnote reference number to 

return to the document.
 4. There are many advantages of using tables–
  • It is an effective way of arranging text.
  • You can catalogue information on a specific topic.
  • Data arranged in a table looks more meaningful, neat and 

organized.
  • Large amount of information can be presented in a concise manner.
 5. a. Creating a Table using the Draw Table option :
   To create a table using the Draw Table option, follow these steps :
   Step 1. Place the cursor where you want to draw a table.
   Step 2. Click on the Insert tab.
   Step 3. Click on the Table button in the Tables group.
   Step 4. Click on the Draw Table option.
   Step 5. Click in the document. The mouse pointer changes to a 

pencil pointer. Start in the upper-left corner where you 
want to place your table and drag to the lower right corner.

     Now, draw rows and columns one by one. The Table Tools 
tab appears for adding styles to the table.

   Step 6. To erase a line or a block of lines, click on the Erase button 
in the Draw Borders group, and then click on the line you 
want to erase.

   Step 7. To change the mouse pointer from pencil to normal, click 
on the Draw Table button on the Draw Borders group or 
press the Esc key.

  b. Creating a Table using the Insert Table option :
   To create a table by using the Insert Table option, follow these 

steps:
   Step 1. Place the cursor where you want to insert a table.
   Step 2. Click on the Insert tab.
   Step 3. Click on the Table button in the Tables group.
   Step 4. Click on the Insert Table option. The Insert Table dialog 

box appears.
   Step 5. Specify the number of rows and columns you want.
   Step 6. Click on OK to insert the table.
  c. Creating a table using the Table button :
   This is the quickest way to create a simple table.
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   To use this feature, follow the steps given below :
   Step 1. Place the cursor where you want to insert the table.
   Step 2. Click on the Insert tab.
   Step 3. Click on the Table button in the Tables group.
   A drop down grid appears.
   Step 4. Drag the mouse down and across the grid to select the 

required number of columns and rows.
   Step 5. Release the mouse button to create the table at the insertion 

point.  
 6. Deleting Cells, Columns or Rows :
  To delete cells, columns or rows, follow these steps :
  Step 1. Select the cell, column or row that you want to delete.
  Step 2. Click on the Delete option in the Rows & Columns group on 

Table Tools Layout tab. You will get a delete drop down list.
  Step 3. Select the appropriate option. If you choose Delete Cells, a 

dialog box appears. Use this to decide what you want to do 
with the other cells in the row or column.

  Step 4. Click on the appropriate button and then click on OK.
 7. Inserting Header and Footer
  To insert header and footer in your document, follow these steps :
  Step 1 :  Click on the Insert tab.
  Step 2 :  In the Header & Footer group, click on the Header button. The 

Header gallery will open.
  Step 3 :  Click on the Blank header style or choose any other style 

according to your requirement. The Design tab will appear 
under Header & Footer Tools. This tab will 

  come only when your cursor is in the header or footer area.
  Step 4 :  Type the header text in the header area.
  Step 5 :  Click on Go to Footer button in the Navigation group. The 

cursor appears in the footer area. Type the text in the footer 
area.

OR
   Click on the Insert tab. In the Header & Footer group, click on 

Footer to display the Footer gallery. Click on the footer style 
you want. Type the text in the footer area.

  Step 6 :  Click on Close Header and Footer button in the Close group of 
Design tab or press the Esc key.

Lab Activity
Ans. Do it yourself.
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Exercise
A. Tick (3) the correct option :
Ans. 1. d.  2.    b. 

More on MS PowerPoint 20107



B. Fill in the blanks :
Ans. 1. Quick Access Toolbar allows access to common commands.
 2. Backstage view is similar to the Office Button Menu of PowerPoint 

2007.
 3. PowerPoint files are called Presentations.
 4. Placeholders are areas on the slide that are enclosed in dotted borders.
C. State 'True' or 'False':
Ans. 1. True  2. False 3. True 4. False
D. Find and match the names of the icons to the words in the box :

Ans.
     New Slide

     My Templates

     Title Slide

     Text Box

     From Beginning

     PowerPoint

     Insert Table

     Insert Chart

     Insert SmartArt Graphic

     Insert Picture from File

     Clip Art

     Insert Media Clip

E. Answer the following questions :
Ans. 1. Features of MS PowerPoint 2010 :
  The Ribbon
  The Ribbon contains multiple tabs, each with several groups of 

commands. Some tabs, like Drawing Tools or Table Tools appear only 
when you are working with certain items like images or tables.

  Quick Access Toolbar
  Quick Access Toolbar is located above the Ribbon. It allows access to 

common commands. By default, it shows the Save, Undo, and Repeat 
commands.

 2. Slides contain placeholders, which are areas on the slide that are 
enclosed by dotted borders.

 3. The placeholders are arranged in different layouts that can be applied to 
existing slides, or chosen when you insert a new slide. A slide layout 
arranges content using different types of placeholders, depending on 
the kind of information in the presentation.

 4. A presentation can be viewed in the following ways after it is ready.
  Reading View : This view includes easily accessible buttons for 

navigation, located at the bottom right.
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  Slide Show View : This view completely fills the computer screen and 
is what the audience will see when they view the presentation.

  Normal View : This is the default view where you create and edit your 
slides.

  Slide Sorter View : In this view, miniature slides are arranged on the 
screen. You can drag and drop slides to easily reorder them, and see 
more slides at one time.

 5. Creating a New Presentation :
  Step 1. Click the File tab. This takes you to Backstage view.
  Step 2. Select New.
  Step 3. Select Blank presentation under available Templates and 

Themes. It will be highlighted by default.
  Step 4. Click Create. A new blank presentation appears in the 

PowerPoint window.
Lab Activity
Ans. Do it yourself.

Exercise
A. Tick (3) the correct option :
Ans. 1. d. 2.   a. 3.   c. 4.   a. 5.   c. 6.   b. 7.   a.
B. Fill in the blanks :
Ans. 1. A procedure always starts with the TO command.
 2. END command is given to end a procedure.
 3. A procedure that is embedded inside another procedure is known as 

Sub procedure.
 4. The SAVE command saves the procedure in secondary memory.
 5. LOAD command loads a procedure from a disk to Primary memory.
C. State 'True' or 'False':
Ans. 1. True  2.   True 3.  True 4.   False 5.   True
D. Which of the following are not valid procedure names?
Ans. 1. SD301 2.   22SS 4.   FORWARD 6.   PROC1+2
E. Define the following :
Ans. 1. A LOGO Procedure is a set of LOGO commands given one after the 

other and referred to by a name to perform a particular task. It is 
actually a program written in LOGO language.

 2. SAVE Command is used to save procedure file.
 3. EDIT Command is used to make changes in an already written 

procedure.
 4. LOAD Command is used to recall a saved procedure.
 5. You can use a procedure within a procedure. This is called nesting of 

procedures.

LOGO Procedures8
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 6. SQUARE is embedded or nested inside the procedure DESIGNSQ. 
SQUARE is called the Subprocedure and DESIGNSQ is called the 
Main procedure or Master procedure.

 7. Recursion means 'going back'. So, as the name implies, a Recursive 
Procedure is a procedure which goes back and uses itself as a part of the 
instructions.

 8. FENCE Command–On giving the FENCE command the procedure 
will draw vertical bars of in–creasing heights, the turtle keeps drawing 
until it goes out of bounds of the screen.

F. Answer the following questions :
Ans. 1. A LOGO procedure is a set of LOGO commands given one after the 

other and referred to by a name to perform a particular task. It is 
actually a program written in LOGO language.

  A procedure is divided into three parts, namely, Title Line, Body, and 
End Line.

 2.  a. The name of a procedure can include letters, numbers or symbols.
  b. The first character should always be a letter.
  c. Blank spaces cannot be included.
  d. Arithmetic operators like +, -, /, * cannot be included.
  e. LOGO command names cannot be included.
  f. Some valid Procedure names are, Circle, B2B, AMIT2 and P$5, 

while the names P 25, 123, X+Y, HT are invalid Procedure names.
 3. To execute the procedure CIRCLE, simply type the name of the 

procedure in the Input box and press the Enter key.

  CIRCLE ¿
  The instructions contained in the procedure get executed and the turtle 

draws a picture on the screen.
 4. Nested Procedures :
  You can use a procedure within a procedure. This is called nesting of 

procedures. Let us understand it with the help of an example.
 5. Yes, we can use more than one variables in a procedure.
  Type the following commands in the Input box.
  TO RECTANGLE : LENGTH : WIDTH
  REPEAT 2 [FD : LENGTH RT 90 FD : WIDTH RT 90]
  END
  You can see from the above example that we can use two or more 

variables while naming a procedure. A colon sign (:) separates the 
name of each variable.

  To get the output you need to type the procedure name followed by two 
numbers, one for LENGTH and one for WIDTH. For example,

  RECTANGLE 100 60
  This will draw a rectangle with length 100 units and width 60 units.
 6. SQUARE is embedded or nested inside the procedure DESIGNSQ. 

SQUARE is called the Subprocedure and DESIGNSQ is called the 
Main procedure or Master procedure.

  Main procedure or Master procedure is a procedure which contains one 
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or more other procedures and a Subprocedure is a procedure which is 
embeded with another procedure.

  Let us take another example :
  Subprocedure :  ARC
     TO ARC
     REPEAT 18 [FD 5 RT 10]
     FD 5
     END
  Main procedure : DESIGN
     TO DESIGN
     CS
     PU
     LT 90 FD 120 RT 90
     PD
     REPEAT 5 [ARC LT 180]
     END
  On typing DESIGN in the Input box, the Main procedure DESIGN gets 

executed and draws the picture by repeatedly using the subprocedure 
ARC.

 7. A procedure is always started with the word TO followed by the name 
of the procedure. When LOGO comes across the command TO, it 
interprets it to be the start of a procedure and the text followed to be the 
name of the procedure.

  When you press the Enter key after typing the procedure name in the 
Command-Input box, an Input box titled To Mode pops up, indicating 
that the computer is ready to accept the primitives to be stored in the 
procedure.

  Now, you can enter the primitives required to achieve the desired task. 
Keep pressing the Enter key after each command. When you have 
typed all the instructions you want to be stored in the procedure, type 
the End command to mark the end of the procedure and press the Enter 
key. A message will appear procedure defined.

 8. Making Changes in a Procedure :
  To make changes in an already written procedure, Edit command is 

used.
  The Syntax of the EDIT command is :
  EDIT “Procedure name”
  It opens the LOGO Editor where you can make changes in the set of 

LOGO commands written in the procedure.
  After making the desired changes, select the Save and Exit option from 

the File menu.
 9. Recursive Procedures :
  Recursion means 'going back'. So, as the name implies, a Recursive 

Procedure is a procedure which goes back and uses itself as a part of the 
instructions. Let us take an example.

  TO STAIR : STEP
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Exercise
A. Tick (3) the correct option :
Ans. 1. c. 2.   d. 3.   a. 4.   b. 5.   a.
B. Fill in the blanks :
Ans. 1. Formulas are used to perform calculations.
 2. Formula must be started with an = (equal to) sign.
 3. Today function shows the current date.
 4. Sorting refers to arranging data systematically.
 5. Cell referencing is mainly of two types.
C. State 'True' or 'False':
Ans. 1. True 2.   False 3.   False 4.   False 5.   True 6.   False
D.  Replace the incorrect word with the correct word in the following 

sentences:
 1.  Excel follows BEDMAS rule for doing calculations based on 

arithmetic formulas.
 2.  Priority value of bracket operator is one.
 3.  A formula or a function in excel always starts with an equal sign.
 4.  In excel, sorting refers to arranging data systematically in an order.
E. Short answer type questions :
Ans. 1. Sum : Sum ( ) function is used to find sum of all digits.
 2. Round : To round off the selected number of the specified number of 

digits.
 3. Count : To count the number of  cells containing numeric data (leaving 

the blank cells), out of a selected range.
 4. Today : To display the current system date.

  FD : STEP
  RT 90
  FD : STEP
  LT 90
  STAIR : STEP
  END
 10. Recursion can be stopped by use of IF statement in a procedure. The 

syntax of IF statement is
  IF : <variable> <condition> [STOP]
  Example :
    IF : UNIT = 100 [STOP]
    IF : UNIT > 150 [STOP]
    IF : UNIT < 90 [STOP]
Lab Activity
Ans. Do it yourself.

MS Excel 2010—Formulae and 
Functions9

Computer-6/17



F. Long answer type questions :
Ans. 1. In Excel, Sorting refers to arranging data systematically in an order. For 

example, you may want to arrange the names of students in an order in a 
worksheet can be in the alphabetical order or in the total marks scored 
by students of the class.

  You may also arrange the data in ascending or descending order.
  To quickly sort your data, the steps are as follows :
  Step 1 :  Select the range of cells whose data needs to be sorted, such as 

A1:A30. The range can include the column titles also.
  Step 2 :  Click on the Data tab.
  Step 3 :  From the Sort & Filter group, click on option to arrange data in 

ascending order, that is, from the smallest to the largest or from 
A to Z. OR click on option to arrange data in descending order, 
that is, from the largest to the smallest or from Z to A.

 2. When you copy a formula to a cell or a range of cells, the row/column 
reference gets automatically adjusted depending upon the row/column 
you are copying the formula to. This feature of Excel is called Cell 
Referencing.

  Cell referencing is mainly of two types :
  a. Relative Cell Referencing
  b. Absolute Cell Referencing
 3. Excel can be used to perform basic mathematical operations such as 

addition, subtraction, multiplication or division for the values in a 
range of cells with the help of formulae. You can even find out the 
average value of the selected cells, and do a lot more.

  Have you ever heard of the BODMAS (Bracket, Of, Division, 
Multiplication, Addition and Subtraction) rule in mathematics? It 
defines the order in which mathematical operators should be used. In 
Excel, there is an E(exponent) instead of O (Of). So, Excel follows the 
BEDMAS rule for doing calculation based on arithmetic formulae.

 4. Function   Purpose Example
  AVERAGE  To calculate the average of a  AVERAGE(B2:B50)
   selected range of numbers 
  MAX  To display the maximum   MAX (A1:A200)
   value out of a given range of 
   numbers
  MIN  To display the minimum  MIN (A1:K1)
   value out of a given range  
   of numbers
  COUNT  To count the number of cells  COUNT(B1:K20)
   containing numeric data 
   (leaving the blank cells), out 
   of a selected range
  COUNTA  To count the number of cells  COUNTA(B1:K20)
   that are not empty (leaving  
   the blank cells), out of a 
   selected range of cells
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 5. Some common errors in formulae :
  Error Possible Reason  Solution
  ###### The column is not wide  Increase the column width
   enough to accommodate  or reduce the font size.
   the number. The number   
   of # symbols may vary. 
  #VALUE  The formula contains invalid  Correct the formula or 
   data. For example, you are  change the cell reference. 
   trying to add a value with a 
   label.   
  #DIV/0!  The formula is trying to divide  Correct the formula 

or 
   a number by 0 or a blank cell  change the cell reference.
   (division by zero).  
  #N/A  Data referred in the formula  Correct the formula or 
   is not available. change the cell reference 
     to make the required data 
     available.
  #REF! The formula refers to a cell Correct the formula or 
   that isn't valid. This can  change the cell reference 
   happen if the cell has been to make the required data 
    deleted from the worksheet. available.
Lab Activity 

Internet10
Exercise

A.  Fill in the blanks :
Ans. 1. Inbox folder of the e-mail account keeps a record of all the received 

mails.
 2. Garh folder keeps the record of all the deleted mails.
 3. Chat is a feature of Internet that helps us to communicate by typing on 

the computer sitting far away from each other.
 4. To send a new mail, we have to click on compose.
 5. Add CC and Add BCC allow us to send e-mail to more than one 

person.
 6. Forward option forwards the message to another person.
B. State 'True' or 'False':
Ans. 1. True 2.   True 3.   False 4.   True 5.   False 6.   False
C. Name the following :
Ans. 1. Search Engines 2. WWW.Yahomall.com
 3. The DM 525 4. Compose
 5. Resend 6. Composed mail

Computer-6/19



. Composed mail
D. Answer the following questions :
Ans. 1. You need the following to use the Internet facility :
  a. A multimedia computer.
  b. A modem and a telephone line connected to it.
  c. An account or registration with an ISP (Internet Service Provider) 

like VSNL and Airtel. The ISP will register your name and give you 
a user name, a password, and the phone number for you to dial for 
connection.

  d. You also need a dial-up network connection, software of the 
particular ISP that helps you to connect. For example, VSNL's 
software is VSNL auto dialer.

  e. A browser or Internet software is also needed that helps you to surf 
the net, like Microsoft Internet Explorer and Netscape Navigator.

 2. It is not necessary that you know the URL or the related websites of the 
information you are seeking. In this situation, Search engines are used 
to get information from the Internet. MSN, Google, and Yahoo are 
some of the most commonly used search engines.

 3. E-mail is the short form of electronic mail. It is the most widely used 
application on the Net.

  E-mails are like letters sent from and to a computer through the 
Internet. These electronic letters can be sent and received only when 
the sender and receiver have an access to the Internet.

  To send or receive e-mails, an e-mail account is needed. There are 
many websites like Gmail, Yahoomail, and Hotmail that allow people 
to open their e-mail accounts free of charge.

 4. To send or receive e-mails, an e-mail account is needed. There are 
many websites like Gmail, Yahoomail, and Hotmail that allow people 
to open their e-mail accounts free of charge.

 5. We can also send Word files, Excel sheets, or pictures by attaching 
them in the e-mail.

Fun To Do

Computer Viruses11
Exercise

A. Tick (3) the correct option :
Ans. 1. b. 2.   d. 3.   d. 4.   c. 5.   d.
B. Fill in the blanks :
Ans. 1. The computer viruses are small software programs that are made in 

such a way that they spread from one computer to another and interfere 
with the computer operation.

 2. VIRUS stands for Vital Information Resource Under Siege.
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 3. Computer viruses are in fact similar to the biological viruses which 
infect the living things.

 4. Multi pirate is hybrid of both boot and program viruses.
 5. Antivirus software is used to prevent, detect and remove malware, 

including computer viruses, worms and Trojan horses.
C. Name the following :
Ans. 1. Stealth Virus 2. Boot Virus 3. Program Virus
 4. E-mail Virus 5. Metamorphic Virus
D. Answer the following questions :
Ans. 1. Antivirus software is used to prevent, detect and remove malware, 

including computer viruses, worms and Trojan horses. Some 
commercial anti-virus scanners use heuristic signatures to look for 
specific attributes and characters for detecting viruses.

  Two software are Kaspersky, AVG.
 2. The word “Heuristic” is Greek for “To find”. When the word is applied 

in the world of computer science, it generally refers to a software that's 
able to resolve a problem with alternative methods with the goal of 
reducing overall processing time. Various software companies use 
heuristics to scan files and programs for suspicious code likely to be 
found in a virus and not in a legitimate program.

 3. Computer viruses are infact similar to the biological viruses which 
infect the living things. They are :

  • Self-spreading and reproductive i.e., they spread from one computer 
to the other computers.

  • They damage the host computer.
  • They can be prevented by using anti-virus software.
  However, Virus is nothing but a computer program written to affect the 

working of the computer. In some cases, they are extremely 
destructive.

 4. It provides protection for :
  • File Anti-virus   • Mail Anti-virus
  • Web Anti-virus   • Proactive Defense
  • Firewall    • Privacy Control
  • Anti spam    • Parental Control
  It scans for viruses and after finding a corrupted file asks for action. So, 

it is very useful to us.
 5. Computer viruses are small software programs that are made in such a 

way that they spread from one computer to another and interfere with 
the computer operations. Virus stands for “Vital Information Resource 
Under Siege”. A Computer Virus can affect another program, can 
erase, corrupt or delete data and use the e-mail network to spread itself 
to other computers.

Lab Activity
Ans. Do it yourself.
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